Bits and Pieces

Use this category to describe KAPping accoutrement extant and desired. Share with us the little bits that make KAPing life easier.

Some servos just jitter. Who knew?

edited January 26 in Bits and Pieces

Spent some time hunting the jitter on my tilt servo:
("https://billboyheritagesurvey.wordpress.com/2021/01/26/arduino-directed-auto-kap-rig-servo-swap/")

I have no idea why this is so, any ideas?

Comments

  • edited January 26

    Bill,
    Nice job on the rig and ground controller. Tracking down the source of servo jitter on these types of systems is seldom straight forward from my experience. It looks like you've already tried several good ideas to isolate the problem so I can relate to your frustration with it. At this point it would be really nice to have access to an oscilloscope to check the rig power supply and servo PWM control signals when the jitter occurs. Understandably, these aren't the most common troubleshooting tools to have lying around, so In lieu of an oscilloscope, here are a few random thoughts I had that may help flush out the root cause of your problem....

    1. I know that you have already physically moved the rig Tx and Rx away from each other and that did not seem to help. It may be worth going a step further by turning the rig video Tx off completely to see if it reduces the jitter. If so, this would indicate that additional Tx/Rx isolation is necessary.

    2. If the jitter is due to a rig power supply issue, then it would likely get worse when the servo is under heavier loads. Try removing the camera from the rig and see if the jitter still occurs when executing an autoKAP sequence with an empty rig. If the jitter goes away when the camera is removed, then this may indicate the need for additional rig power supply modifications.

    3. Switching from a Futaba to a Swiss Savox SH 0256 servo to eliminate the jitter is helpful information and provides a clue as to what is going on as well. The trick is finding out what that clue is! :) The first thing that comes to mind is that the two servos likely have different max slew rates and different instantaneous input current requirements for step command changes. The faster servo will likely require more instantaneous current from the power supply when commanded to move quickly during a tilt change. If this is true, and the rig power supply bypassing/distribution is marginal, then this may result in jitter occurring with one servo but not the other. One way to test this is to see if the jitter still occurs with the Futaba servo when manually commanding a very slow tilt change using the ground transmitter tilt potentiometer.

    4. Going out on a limb on this one, but I suppose there is some chance that the rig Rx is interfering with the servo electronics... you might try dangling the receiver further away from the tilt servo to see if it impacts the jitter...

    5. In the unlikely event that your Futaba servo is just plain faulty, you might try plugging it into another rig to see how it performs when commanded by a different system.

    I hope some of this helps Bill. If it does look like the issue is with your rig power supply, then I have a few things you can try that have helped me with similar issues...

    Good hunting!
    Mike

  • Thanks for taking a look Mike,
    Looks like voltage is the issue. Not being one to leave things alone, to shave off some weight , I swapped in a dinky 800mAh Lipo for the heavier 1300mAh to get a better balance and the tilt servo become unstable. The next act in this sorry drama will be to re-wire the 5V supply. The 5v feed is taken from a 5v outlet on the vTx. Minimum voltage on the vTx is 6v and the max for the RC Rx is 5v. I have tried to run the RCRx on a separate supply with no advantage so my hope is a 5V regulator will smooth things a bit.

    The Savox is a 'high torque' model and definitely does better than the Futaba but the lower ampage supply produced some random jerks when running with the camera in the rig, it does ok with out the load ( as suggested at 2 above) .

  • Bill - this may be completely irrelevant, but years ago I had a tilt servo jitter problem. Eventually I discovered that the problem was due to electrical contact between the screw holding the servo to the tilt arm and the tilt arm itself. Normally the plastic servo horn insulates the two but I had made the hole in the tilt arm too small and so as the arm tilted it came into electrical contact with the innards of the servo. Making the hole bigger fixed the problem. The problem only happened with certain (metal-geared?) servos.

  • Dave,
    Although this has been an issue this rig has nylon bearings and a plastic 'bridge' between servos. I'll check but I'm pretty sure it's well insulated.

  • Most of the replies above are in line with my experience too.
    As you know, the servo motors can pull a significant current (even up to amps when heavily loaded). If the available current is insufficient jitter can occur. When using a lipo battery the available current is set by the discharge rate (eg 20c) rather than the capacity (eg 1000 mAh) . As the lipos age the discharge rate reduces thereby limiting the available current.
    The current available to the servo motor is also limited by the conductivity of the connecting wires. Any poor or corroded joins will reduce the available current. The voltage drop across these these poor joins can also reduce the voltage seen by the motor which can cause jitter too.
    I use a 5v linear regulator ( L7805) between battery and the receiver, plugging the servos directly into the receiver to minimise
    likelihood of poor joins.

Sign In or Register to comment.